0 like 0 dislike
96 views
I am noticing a difference in particle behavior when I have the Model under Backdrop>3D Layers turned on compared to it being turned off. It was my impression that this object was for visual reference only. How do I control and/or disconect the Model from affecting my particles behavior, while the still maintaining the ability to view the Backdrop Model?

Thanks
by joshuaf51 (130 points)

1 Answer

1 like 0 dislike

Hi,

Indeed they are for visual reference, but also "behavioral" reference, they're useful to make sure your particles will collide the right way with your ingame scene, even though they're not exported with the effect to the game engine.

By "affecting the particles behavior", do you mean particles are bouncing off the backdrop?

If you have a collision evolver, or a physics evolver with the 'WorldInteractionMode' set to anything else than 'None', then that's normal behavior.

First, in the treeview, on the right of the backdrop you have both a checkbox and a little eye icon, as you have noticed, the eye only hides the backdrop, but it still collides, and the checkbox entirely removes the backdrop, so it's neither visible nor collidable :

A: disable entirely: not visible / not collidable
B: hide, but still collidable

There's one state missing, that would be "visible, but not collidable", which is what you're looking for.

To do this, you'll have to use a small trick: each collidable backdrop has a "CollisionFilter" property, that defaults to '0':


Each physics and collision evolver has a "FilterID" property, which also defaults to zero.
They will collide with all backdrops that have the same value in their 'CollisionFilter':

 

so you can just select the backdrops you don't want your particles to collide with, and set their "CollisionFilter" property to a value different from the one in your physics or collision evolver, for instance "-1",  or "100", or whatever, and your particles should stop colliding with these backdrops.

by Julien (32.8k points)
This is a solid explanation and is exactly what I needed. Thanks Julien.
...