0 like 0 dislike
2.1k views

Hi, I'm using PopcornFX Cartoon FX Pack [https://www.assetstore.unity3d.com/en/#!/content/28347] and particles work when I use Unity Editor, but when I build the Android package and install on a device, effect are not showed.

I followed these 2 links I found googling for a solution:

I did all the steps listed there but still I can't see PopcornFX Particles running on device, just on Unity Editor.

What am I missing or doing wrong?

by MostroLabs (130 points)

1 Answer

0 like 0 dislike

Hi,
Which version of Unity are you using? Which graphics API?
Can you check the logcat for PopcornFX-related errors? (see http://wiki.popcornfx.com/index.php/Unity/Identifying_Errors#Android)?

Did you build the pack's index as instructed in the links you mentioned?
Depending on your device, you might have to enable external storage in the player settings, too.

by Raphael (10.6k points)
I'm using Unity 5.2.2p3 on Mac OS X 10.11.1

In I have checked "Player Settings -> Other Settings -> Auto Graphics API", these are my Player settings: http://i.imgur.com/0Ms9RmX.png

I built the package following all steps mentioned in the links above.

I have 2 devices, a Galaxy S4 with android 4.2.2 and a Motorola Moto X 2nd gen with Android 5.1 I can't see the PopcornFX Particles in none of them.

When I run  ./adb logcat | grep "PK_LOG" there's no output, but when I run just ./adb logcat I can see this output repeating constantly:

I/Unity   (28722): DllNotFoundException: HH-UnityPlugin
I/Unity   (28722):   at (wrapper managed-to-native) PKFxManager/S_DynamicSymbols:ShareSecrets (intptr)
I/Unity   (28722):   at PKFxManager..cctor () [0x00000] in <filename unknown>:0
I/Unity   (28722): Rethrow as TypeInitializationException: An exception was thrown by the type initializer for PKFxManager
I/Unity   (28722):   at PKFxFX.StartEffect () [0x00000] in <filename unknown>:0
I/Unity   (28722):   at C1P_FX.Start () [0x00000] in <filename unknown>:0
I/Unity   (28722):
I/Unity   (28722): (Filename:  Line: -1)
I/Unity   (28722):

how can I fix it?
I reimported the package from Unity's Asset Store and I have this error too:
http://i.imgur.com/VCYpB8X.png
That means you don't have the Android plugin in your project.  
Make sure to import the file Assets/Plugins/Android/libHH-UnityPlugin.so from the Android package (http://u3d.as/as6).
The collision issue means the target platforms of the native plugins are not set properly and would result in redundant files in the end package.  
Make sure the .dll files in Plugins/x86 target Editor/Standalone for x86/Windows,
the .so files : Editor/Standalone for x86 Linux
Same for the files in x86_64 but change the CPU setting to x86_64.
Unity used to set those up automatically but stopped doing so for whatever reason...
I bought this package https://www.assetstore.unity3d.com/en/#!/content/28347
why doesn't it contain the libHH-UnityPlugin.so file?
So, do I have to spend $250 just to have one file?  o.O
The android version of the discovery plugin was originally not available, but it now is. You can download it here : http://www.popcornfx.com/download/  
Keep in mind this plugin only allows you to play signed effects verbatim.
...