0 like 0 dislike
35 views

I have created a ridden particle effect and tried to attach a decal material to it. Now when I do this with a PopcornFX Material it crashes but doing this with a UE4 particle effect it works just fine. Below is an image of the decal material and the renderer of the particle. 

Link here -> https://i.gyazo.com/8443304fdc3038dd670b9a6bf292eeb9.png

 

asked by Jamesking96 (960 points)
Hi James,

Thanks for reporting this issue. We'll try to reproduce and come back to you.

1 Answer

0 like 0 dislike
Hi James,

We were able to reproduce the crash, and will work for a fix in future days.
I asume you were trying to use "M_PK_Default_Decal_AlphaTest" material, right ?

You should be able to use other material from the engine (or even one of your own) even if it is in deffered decal domain.

Thanks again for reporting this issue.

Cheers
answered by Maxime (5.3k points)
Hi Maxime,

It's good to hear that you are working on a fix. however, your assumption isn't 100% correct I have tried using the "M_PK_Default_Decal_AlphaTest" & M_PK_Default_Decal_Blend" and they do not show as visible during play and when looking in wireframe it looks as though they are not even spawned  (Which is weird because when the material is changed from Deferred Decal to a different Material Domain it works fine). I also tried using my own custom made decal material with the provided setting above this one once again did not show visible for unknown reasons with the same material I changed the Decal Blend Mode from 'Translucent' or 'Normal' to 'Deferred Normal' applying this to the particle system would crash the engine.

Thanks for the support and I'm still playing with the settings to try and find a work around.
Okay i see, M_PK_Default_Decal_AlphaTest and M_PK_Default_Decal_Blend are both made to be used for pure decal, and not on particle sprite. (Usage for particle sprite is not checked).
For what i understand for now, this is both because of us, and because of the way UE render decals. Try to activate the "DBuffer Decals" option if not done yet in your engine settings. (you can also open DefaultEngine.ini and set to "True" the r.DBuffer option).
However, we should be able to handle this situation, and it should not crash because of one of our material.

If you use only static light in your scene, take a look at this page : http://www.worldofleveldesign.com/categories/ue4/ue4-decals03-decals-do-not-render-in-indirect-light.php (it may help)

I will look deeper next week this issue and fix it asap.

Please let me know if you found any workaround, or solution, for your problem.

Bests,
Maxime.
...