0 like 0 dislike
24 views

I've been noticing more and more that particle effects I have in Ue4 with collisions enabled don't seem to work as I initially thought, I have some trigger boxes and objects set with no collision that the particles still interact with as if they do have collision set on them.

 Example Here: https://i.gyazo.com/33589d2ea164a0791edbd1669d0c3b82.mp4

Now I've also completely removed collisions from the mesh but yet the particles still collide with the object (As shown). Now I know that I can the Collision Filter setting in the popcornFXSceneActor but what is the best way to ignore specific object collisions without making changes that would affect the objects collision with everything else?  

Note: Collisions also seems to happen with meshs where there is no face i.e. when a set offences are all imported together as a combined mesh the particles seem to collide with something in the air despite collisions being removed and there being to faces 

My belief is that if I Could understand what popcorn is using to register collisions I would be able to work around.

asked by Jamesking96 (900 points)

1 Answer

0 like 0 dislike
Hi James,

This sounds related to https://answers.popcornfx.com/1274/popcornfx-ignores-collision-settings-on-meshes-in-unreal-4

UE4 doesn't refresh the physx scene when not in play or simulate mode. When hitting play you should have the correct behaviour.

Cheers
answered by HugoPKFX (15.5k points)
...