[Unity3D] Support android API version....?

0 like 0 dislike
41 views

PopcornFX does not support Android 4.4.2 (API 19) version?

If so, please support Android 4.4.2 (API 19).
Android 4.4.2 (API 19) is still being used in many places.
Please.

Thank you! You are the best!

FYI, this is the Game we're developing. (iOS/Android)

Youtube Link : https://youtu.be/Hyp7LVafkSY

asked Nov 28, 2017 by sonhy1 (220 points)

2 Answers

0 like 0 dislike
 
Best answer

Final answer and closing:

The next release (PopcornFX v1.12.3) will be back to be built with Android NDK api 19 compatibility for arm (and api 21 for arm64).

answered Nov 29, 2017 by Jordan (14,550 points)
0 like 0 dislike

We dropped NDK < 21 support since we implemented support for arm64 (arm64-v8a), because Android NDK only support arm64 only since api 21.

We'll think about it, but for now, assume it is not supported for the stock Plugin builds. But, it could be arranged with a custom PopcornFX SDK licensed build.

answered Nov 28, 2017 by Jordan (14,550 points)
Unity3D does not currently support 64-bit native plugins on Android. So you must use a 32-bit version. Notice the values for the "Architecture" option in the Player Settings for the Android target (in the Unity Editor). They are ARMv7 and x86, both 32-bit architectures.

So, arm64 is not required.
Why are you supporting arm64?
Yes, Unity does not support arm64 yet, but Unreal Engine, and other engines do.
We are looking into it, please contact-us we'll keep in touch.
Yes, Thank you very much. :)
...