PopcornFX Particles Only Render In Left Eye on HTC Vive in Unity

0 like 0 dislike
29 views
I've tried it with mesh particles, bill board particles and a mix.

As this is using a VIVE everything is going through Steam VR.

I'm using Unity 5.3.6p1 (can't change for project reasons).

EDIT: We suspect the problem comes when SteamVR adds the second camera for the right eye but doesn't add the PopcornFX rendering plugin component.
asked Aug 29 by feanix (1,150 points)
Hi feanix,

Are you using the lastest version of the PopcornFX plugin ? (v2.9p5)
Yup, I believe so.

http://i.imgur.com/K72bN5V.png
Added an edit above.
If I remember correctly, with SteamVR you need to add the PkFxRenderingPlugin component on the camera prefab in Assets/SteamVR/Prefabs/[CameraRig]/Camera (head).

1 Answer

1 like 0 dislike
 
Best answer

The problem in this case was caused by the new Single Pass rendering method. Reverting to Multi Pass fixes the issue, obviously at the cost of some performance gains, 

To fix:

  1. In the Build & Run Dialog, click the "Player Settings" button
  2. In the inspector pane that then appears, look for the "Stereo Rendering Method" field
  3. Choose "Multi Pass" instead of "Single Pass"
answered Aug 31 by feanix (1,150 points)
...