WARNING : This site is outdated and the PopcornFX team will no longer answer your questions here.
For all support questions please go to our Discord server
1 like 0 dislike

If you have a mesh in Unreal 4 with any sort of collision on it then PFX will collide with it even if the object's collision settings are set to "No collisions" or if "World Static" and "World Dynamic" are disabled. This causes an issue with objects that need collision volumes for gameplay reasons but shouldn't affect pure visual things like particles.

This happens in Unreal 4.12 with the PopcornFX 1.2.0 plugin.

To repro:

  • Load a blank level
  • Drop in an effect that has particles spawning in a flat plane and move downwards with collision on and set to "Die on Collision"
  • Drop one of the standard cube meshes into your level
  • In the collision settings for the cube choose the "No Collisions" preset
  • Observe that despite the new settings particles will continue to die as soon as the touch the collision mesh for the cube
Expected behaviour: Particles should respect the collision settings of meshes.


by feanix (1.2k points)

1 Answer

0 like 0 dislike
Best answer

Hi feanix,

Thanks for your detailed repro steps. I was able to reproduce it on 4.10.4 and in 4.12.5 easily but it seems to occur in EWorldType::Preview but not in EWorldType::PlayInEditor/Simulate/Standalone.

After some investigation, it seems that CascadeFX is also affected by this behavior. Our underlying implementation of scene collisions depends on PhysX, so my guess here is that if not in Simulate or Play mode, the Physx scene is just frozen.

Do you still have the issue while in PIE ? If so, I'll continue investigating.

Thank you.

by HugoPKFX (17.7k points)
Thanks for having a look, Hugo. I'll try testing in PIE tomorrow when I'm back in the office.

Out of interest, does PFX have a scene depth buffer collision feature like cascade GPU particles do?
Right now there is no screenspace collision feature as in CascadeFX, but that is a neat feature we might dig into some time around.
Okay, so PIE does not seem to fix the problem. It sounds like it may be an issue with Unreal rather than PFX? Do you have any way to escalate this to Epic?
Hi feanix,
you could use answers.unrealengine.com if you are sure that this is indeed a UE4 related issue.
On my end, however when I reproduce the issue, it doesn't persist while in Play mode, either with CascadeFX or PopcornFX, so I'm not sure what the issue is.