0 like 0 dislike
1.2k views
Hi,

I am trying to open a project using PopcornFX and UE4.12.2.

I encountered an error while generating the project's file in Sources/PopcornFX/PopcornFX.Build.cs:

Line 70: RulesCompiler.GetModuleFilename( this.GetType().Name ) is deprecated. using the ModuleDirectory property of ModuleRules class does the trick.

So on line 70, replacing "Path.GetDirectoryName( RulesCompiler.GetModuleFilename( this.GetType().Name ) )" with "this.ModuleDirectory" works...

 

But then. I have a fatal error that says:

PopcornFXPrivatePCH.h(55): fatal error C1083: Cannot open include file: 'hellheaven/hellheaven_api/include/hh_precompiled_default.h': No such file or directory

I would like to know if anybody would have an idea as of why it doesn't work.

Cheers!

Hayaweh
by Hayaweh (220 points)

1 Answer

2 like 0 dislike
 
Best answer

Hi,

Are you using the latest UE4 Plugin v1.1.2 or v1.2.0 (! v1.2.0 updates to PopconFX 1.10 !) ?

The fix your have done, is exactly what's been done in the 1.1.2 release. Among other fixes for UE 4.12.

About the PopcornFXPrivatePCH error: try to regenerate your VS project, then explicitly Rebuild in visual studio (or delete all "Binaries" and "Intermediate" folders in your poject folder, and in the plugin "PopcornFX" folder).

 

 

by Jordan (14.6k points)
Hi,

It seems like the last version I had access to was 1.1.1. I will try with 1.1.2!

Thank you for your help regarding the PCH error but Rebuilding/purging the Intermediate folders did not seem to make a difference.
I do not have the 1.1.2 version yet. I will try asap.

EDIT: After testing with 1.1.2.. It works! :) Thanks!
I am using the release branch of the Popcorn FX UE4 Plugin (v1.3 currently) with Unreal Engine 4.12.5, and I've run into this exact same fatal error when trying to build.

PopcornFXPrivatePCH.h(55): fatal error C1083: Cannot open include file: 'hellheaven/hellheaven_api/include/hh_precompiled_default.h': No such file or directory

I've tried it with several other versions of the Popcorn FX UE4 plugin including the one that worked for the OP, as well as older versions of Unreal Engine, all with the same error.

I have also tried regenerating and then rebuilding/purging Binaries and Intermediate folders, still getting the same error.

I saw this bit on the wiki:

'Sometimes, the archive has not been extracted properly due to path too long, resulting in missing files. Try to extract it closer to root of your drive, then copy paste the directory.'

So I tried that, still no luck.

I am using an up to date Visual Studio 2015.

Surely other people have run into this by now, as I've tried it on 3 computers with the exact same result. I would really appreciate any help getting this up and running.

Thanks,

Jonathan

EDIT: Apparently downloading the file from the clone or download button does not include the SDK files needed to compile, so you have to use link to the Latest Release in the instructions. I'm obviously not the most GitHub saavy person, but it would be nice to have some clarification on that.

Anyhow, up and running now :)
Hi Jonathan,
Glad to hear you could have fixed it.

Indeed, the repository doesn't include the PopcornFX SDK libraries: as the PopcornFX SDK is also under heavy development, if you can notice, each UE4 plugin version is compatible with a different PopcornFX SDK/Editor version. If we were to include the SDK libraries in the repository we would need to commit them every time there is a new version, which happens a lot.

So what we do is the release/develop branches of the repository only contains the plugin source, and depending on whether we find the "PopcornFX_Runtime_SDK" nested within the plugin, we now if it's an "embeded" build or a "source" build (you can view that in the plugin's build.cs.

On our side, we build the plugin with the source SDK, while users should (like you found out) copy/paste the latest "PopcornFX_Runtime_SDK" folder within the repository.

Of course, if you plan to use the release branch of the plugin, make sure to update the PopcornFX_Runtime_SDK folder each release.

PS: This is all described in the Readme.md in the plugin repository.
Hope that clarifies a bit.
You Can use LONG PATH TOOL for solve this problem.It is great.
...